Home Forums Reply To:


You can try to update your /etc/network/interfaces file with the following code snippet to enable the wan, lan0, lan1 interface ports. This way you won’t have to re-build for systemd.

auto lo br0
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet manual

allow-hotplug lan0
iface lan0 inet manual

allow-hotplug eth1
iface lan1 inet manual

iface br0 inet dhcp
bridge_ports lan0 lan1 wan

With my current systemd-networkd configuration, I am able to plug-in an Ethernet cable between the wan, lan0, & lan1 ports and my network connection is retained. When switching ports, I get the following output:

root@espressobin:~# [  571.902010] dsa dsa@0 wan: Link is Down
[  571.905604] br0: port 3(wan) entered disabled state
[  579.018470] dsa dsa@0 lan0: Link is Up - 100Mbps/Full - flow control rx/tx
[  579.025461] IPv6: ADDRCONF(NETDEV_CHANGE): lan0: link becomes ready
[  579.039239] br0: port 2(lan0) entered blocking state
[  579.044227] br0: port 2(lan0) entered forwarding state  

Since my network ports are bridged with the bridge set to DHCP and all the network interface ports are on the same nic, the IP address is the same when switching between interfaces. I’m able to configure the bridge to a static IP address. There may be a way to set a different static address to the bridge depending on which network interface port is connected, but I am unfamiliar with how to correctly set-up that kind of network configuration. My first thought would be to look at defining a udev rule to handle this, but there may be a better option. Let me know if you are able to get a different ip address for each interface, I’d be interested to see how the network is configured.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop