Home Forums Hardware discussions boot stuck at SVC REV: 5, CPU VDD voltage

This topic contains 5 replies, has 4 voices, and was last updated by  John Hasler 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #38192

    anubisg1
    Participant

    I am not sure if this is related to software or hardware. I’m typing it here because i canot reach the bootloader apparently so i’m assuming this is not a software issue.

    When i boot my v7 board, around 70% of the times, the boot stops very early in the process and the only output i have in the console is the following

    TIM-1.0
    WTMI-devel-18.12.1-e6bb176
    WTMI: system early-init
    SVC REV: 5, CPU VDD voltage: 1.155V

    Any idea what the problem is?

    #38406

    Kevin
    Keymaster

    Hi anubisg1,

    Did you use any custom built bootloader image?
    Looks like it is stuck at ddr testing.
    thanks

    Kevin

    #38477

    John Hasler
    Participant

    I’m seeing the same problem. I’m using the uboot image provided by Armbian.

    #38480

    John Hasler
    Participant

    I’m using a 12.58 V regulated supply [1]. No SD card in the slot and no ethernet cables plugged in. I have it connected to a pc on which I am running Minicom via the microUSB connector. The board does not start up reliably. Usually it stops after the CPU voltage message but sometimes it produces no output at all.

    The behavior is the same whether I turn the power supply off and back on, unplug and plug the barrel connector, press the reset switch, or issue the “reset” command at the Marvell prompt.

    Note that the hang occurs *before* any environment variables are read so it cannot have anything to do with any changes I made to configure the board for Armbian.

    It’s beginning to look like I will have to return this board for a replacement or a refund.

    [1] The board has a 13 V zener/surge protector across the 12 V input. 12 V Wallwart-type power supplies output as much as 18 V depending on load. Don’t use them. Even if they don’t burn out the zener it can get quite hot. On the other hand, the board should work fine with inputs as low as 5.9 V as long as you aren’t using ay peripherals that need 12 V.

    #38517

    dasbee
    Participant

    I had the same problem after loading the Armbian recommended (required) uboot at 1GHz/800Mhz. So, I tried the slower speed configurations. Both the 600/600 and the 800/600 appear to be more stable with respect to this booting issue. I suspect there is a race or something like it in the uboot code that is glitching the startup code. I notice that the CPU Vdd is lower when I run at these lower clock speeds. Instead of 1.51 (or so) it runs closer to 1.03 (or so). I don’t remember the exact values, but you should be able to get the point.

    So, if you see this issue, load the slower config. Chances are uboot needs some work.

    Ah wait. I rebooted several times in a row and everything was fine. Now, just now I restarted the machine and it is stopping at the same old boring point. I’m going to go back to the 600/600 speed to see if that makes it more reliable.

    #38520

    John Hasler
    Participant

    I returned my unit to Amazon and got a replacement. It worked fine for a while but now the same problem is back.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop