Home Forums Getting Started Boot without Kermit

This topic contains 10 replies, has 5 voices, and was last updated by  steven 1 year, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #520

    tom.i
    Participant

    Hi all,
    is there any other possibility how to boot without Kermit app?
    I’m using VoidLinux distribution and there is no Kermit, C-Kermit app. 🙁

    EDIT:
    Oh… what a fail :-/
    I’ve just scrolled down on this page, and I see that there is Minicom app which is in VoidLinux so I’ll try it 😉

    #526

    tom.i
    Participant

    Can someone tell me, how can I boot over U-Boot from minicom?
    1. I did copy whole image of Archlinux to SD card as mentioned here: http://wiki.espressobin.net/tiki-index.php?page=Boot+from+removable+storage+-+ArchLinux
    2. Insert SD card to SD card slot.
    3. Plugin 12V
    4. Plugin USB to my PC (VoidLinux).
    5. There is some output from starting EspressoBin but I can’t write anything there:
    https://pastebin.com/2rYyChgi

    I’ve tried “Echo” function from MiniCom app, but it’s not possible to insert there normal text, I can delete whole output and if I write some comands after “Marvell>” there is no response.

    Can anyone help me please?

    #533

    Wayne Yang
    Keymaster

    Have you ever tried other PC? I try putty on windows system and follow the instruction, system is able to boot up normally. I think your issue is related to PC setting.

    #534

    tom.i
    Participant

    No, I haven’t tried another PC, I just tried it at home. I can try it on Fedora22 (work PC), but I think that it isn’t problem of the PC.

    #574

    cuddlepuncher
    Participant

    I had some trouble with minicom. Then I remembered that screen does serial connections as well and is simpler and easier in my experience. Worked perfect for me. Just do
    sudo screen /dev/ttyUSB0 115200

    #575

    tom.i
    Participant

    Cool man, I’ll check it.

    I’ve tried to boot from Windows manchine and it works. I’m going to switch it back to Linux 😛

    #786

    stappers
    Participant

    Text from https://pastebin.com/2rYyChgi `
    Welcome to minicom 2.7.1

    OPTIONS: I18n
    Compiled on Apr 18 2017, 20:09:48.
    Port /dev/ttyUSB0, 21:47:55

    Press CTRL-A Z for help on special keys

    Booting Trusted Firmware
    BL1: v1.2(release):armada-17.02.0:
    BL1: Built : 09:42:03, Jun 2 2NOTICE: BL2: v1.2(release):armada-17.02.0:
    NOTICE: BL2: Built : 09:42:04, Jun 2 20NOTICE: BL31: v1.2(release):armada-17.02.0:
    NOTICE: BL31:

    U-Boot 2015.01-armada-17.02.0-g8128e91 (Jun 02 2017 – 09:41:51)

    I2C: ready
    DRAM: 2 GiB
    Board: DB-88F3720-ESPRESSOBin
    CPU @ 1000 [MHz]
    L2 @ 800 [MHz]
    TClock @ 200 [MHz]
    DDR @ 800 [MHz]
    Comphy-0: PEX0 2.5 Gbps
    Comphy-1: USB3 5 Gbps
    Comphy-2: SATA0 5 Gbps
    Now running in RAM – U-Boot at: 7ff2b000
    U-Boot DT blob at : 000000007fa18168
    MMC: XENON-SDHCI: 0
    SF: Detected W25Q32DW with page size 256 Bytes, erase size 4 KiB, total 4 MiB
    PCIE-0: Link up (Gen1-x1 2.5GHz, Bus0)
    SCSI: SATA link 0 timeout.
    AHCI 0001.0300 32 slots 1 ports 6 Gbps 0x1 impl SATA mode
    flags: ncq led only pmp fbss pio slum part sxs
    Net: neta0
    Hit any key to stop autoboot: 0
    *** ERROR: `serverip’ not set
    *** ERROR: `serverip’ not set
    Bad Linux ARM64 Image magic!
    Marvell>>
    `

    #788

    stappers
    Participant

    The

    Hit any key to stop autoboot: 0
    *** ERROR: `serverip’ not set
    *** ERROR: `serverip’ not set
    Bad Linux ARM64 Image magic!
    Marvell>>

    was an error and board side, not at the side of terminal emulator.

    #790

    tom.i
    Participant

    @stappers – as you can see from my comment I wrote, that I couldn’t type there anything.
    Fortunately @cuddlepuncher helped me with screen and it works like a charm 😉

    #792

    stappers
    Participant

    So the actual error was “can’t type anything”.

    The change in terminal emulator to get it working,
    was most likely a change to a terminal emulator that doesn’t check CTS/RTS.
    (CTS Clear To Send, RTS Request To Send )

    In minicom it can be disabled by setting “Hardware Flow Control: No”
    at serial port settings.

    #818

    steven
    Participant

    putty works with serial port, and I used it to setup the initial u-boot.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop