Home Forums Hardware discussions Expected idle temperature and possible SoC hw defects

This topic contains 3 replies, has 3 voices, and was last updated by  aisrael 1 month, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2075

    kamineff
    Participant

    What should be the SoC temperature at an idle state? Mine is getting above 80C while simply waiting at U-Boot prompt and I can’t have the OS booted no matter what kernel version I try – it simply resets to U-Boot at a random point of the startup process. It’s been sporadically rebooting ever since I received it in May so I haven’t ever seen it running longer than a couple of days but it deteriorated with time so that now I can’t just get to the OS login prompt. When I saw it first I suspected it’s something with my power supply or my OS kernel build but now I tried it with 60W AC adapter and tried multiple kernel versions from vanilla 4.4.52 to custom built 4.18.7 with exactly the same result the only suspicion left is a SoC hardware defect.

    #3829

    ion.dulgheru
    Participant

    I also have the same issue.
    Do you have the version with a 1G DDR chip?

    #5901

    aisrael
    Participant

    My Board (v5 1G ram, 2*512mb Chips) suffers from spontaneous reboots as well.
    I have only observed them when transferring a set of files via various protocols.

    After some time (30s-2m) it always reboots.

    I’ve tried to fix the issue by putting heatsinks on all ic’s on the board.
    I also added a 40mm Cooler to cool the SoC even further.

    All theses measures didn’t fix the problem or changed the behavior of the board to the better in any way.

    Transfering with rsync (instead of minio) over ssh put the cpu under a load of 30% each and the total system consumed not more than 50mb of ram.

    Its sad because after having it sit here for a while I finally took the time to setup the OS and thought this board was perfect to augment my Cloud operated Infrastructure with something more resilient and decentralized.

    I am running Openwrt 18.06 on a 4.14.95 Linux Kernel.

    Trying to find a solution to the problem I stumbled across this Thread – I will try to find concrete evidence but I am suspecting a Hardware Problem as well.

    #5902

    aisrael
    Participant

    I Uploaded the “newest Bootloader” from the “Tech Specs” Page and suddenly this Bricked my Machine.

    Unbricking it seemed to be the Solution to my Problem. I haven’t seen a spontaneous reboot under IO load so far. I will run a test overnight to see if my Board is finaly stable.


    1. https://dl.armbian.com/espressobin/u-boot/rescue/
    2. https://forum.armbian.com/topic/8075-espressobin-rescue-instruction-for-macronix-spi-chip/?page=2&tab=comments#comment-62281
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop