Home Forums Software discussion Openwrt 18_06 reboot

This topic contains 4 replies, has 4 voices, and was last updated by  Shannon 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3861

    lrlopezv66
    Participant

    I bought 4 unit of espressobin to install openwrt
    I download globalscale-espressobin-ext4-sdcard.img.gz (https://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa53/) and create de SD with the following:

    zcat openwrt-18.06.0-mvebu-cortexa53-globalscale-espressobin-ext4-sdcard.img.gz > /dev/sdX

    in expressobin:
    setenv bootcmd ‘load mmc 0:1 0x4d00000 boot.scr; source 0x4d00000’
    savenev

    openwrt Ok!!!!!!!!, But Espressobin reboot constantly……start with openwrt and reboot …etc ¿do you know what is the problem???.

    the first message in consola is:

    root@OpenWrt:/# [ 202.203455] random: crng init done
    [ 202.207003] random: 1 urandom warning(s) missed due to ratelimiting.

    and late the system reboot (after 5, 10 o x minute) I don’t have log (var/log)

    Can you help me?????

    In the reboot moment I can see the following:

    root@OpenWrt:/tmp/log# TIM-1.0
    WTMI-armada-17.10.5-bb8f823
    WTMI: system early-init
    SVC REV: 4, CPU VDD voltage: 1.108V

    Fill memory before self refresh…done

    Now in Self-refresh Mode
    Exited self-refresh …

    Self refresh Pass.
    DDR self test mode test done!!
    Vref read training
    ===================
    Final vdac_value 0x0000001F

    Vref write training
    ===================
    Final vref_value 0x0000001F

    DLL TUNING
    ==============
    DLL 0xc0001050[21:16]: [3,35,1c]
    DLL 0xc0001050[29:24]: [6,2b,18]
    DLL 0xc0001054[21:16]: [7,2f,1b]
    DLL 0xc0001054[29:24]: [a,2d,1b]
    DLL 0xc0001074[21:16]: [0,3f,1f]
    DLL 0xc0001074NOTICE: Booting Trusted Firmware
    NOTICE: BL1: v1.3(release):armada-17.10.3:39a62a1
    NOTICE: BL1: Built : 15:40:57, Jun 1 2NOTICE: BL2: v1.3(release):armada-17.10.3:39a62a1
    NOTICE: BL2: Built : 15:40:59, Jun 1 201NOTICE: BL31: v1.3(release):armada-17.10.3:39a62a1
    NOTICE: BL31:

    U-Boot 2017.03-armada-17.10.2-g14aeedc (Jun 01 2018 – 15:39:10 +0800)

    Model: Marvell Armada 3720 Community Board ESPRESSOBin
    CPU @ 1000 [MHz]
    L2 @ 800 [MHz]
    TClock @ 200 [MHz]
    DDR @ 800 [MHz]
    DRAM: 1 GiB
    U-Boot DT blob at : 000000003f7161b8
    Comphy-0: USB3 5 Gbps
    Comphy-1: PEX0 2.5 Gbps
    Comphy-2: SATA0 6 Gbps
    SATA link 0 timeout.
    AHCI 0001.0300 32 slots 1 ports 6 Gbps 0x1 impl SATA mode
    flags: ncq led only pmp fbss pio slum part sxs
    PCIE-0: Link down
    MMC: sdhci@d0000: 0, sdhci@d8000: 1
    SF: Detected mx25u3235f with page size 256 Bytes, erase size 64 KiB, total 4 MiB
    Net: eth0: neta@30000 [PRIME]
    Hit any key to stop autoboot: 0
    328 bytes read in 7 ms (44.9 KiB/s)
    ## Executing script at 04d00000
    7885 bytes read in 6 ms (1.3 MiB/s)
    7323656 bytes read in 397 ms (17.6 MiB/s)
    ## Flattened Device Tree blob at 04f00000
    Booting using the fdt blob at 0x4f00000
    Using Device Tree in place at 0000000004f00000, end 0000000004f04ecc

    Thanks for ypu help

    #3912

    armbian
    Participant

    > do you know what is the problem?

    Yes. Openwrt, which you are trying to use, is on the proof of concept level. Perhaps not even there. Don’t know if there is any better version …

    Check this https://www.armbian.com/espressobin/ which has far the best firmware, u-boot and kernel for Espressobin. OS = Debian/Ubuntu style and you can try to run Openwrt in a Docker container … if you need this kind of network handling. It might be the only option unless you are willing to put some effort and bringing OpenWRT up.

    #9041

    Gandalf
    Participant

    I get the same problem with one of my V7 1Gb noEMMC EspressoBinBoard.
    It has exactly the same version of UBOOT and BOOTLOADERS…

    I will try to upgrade uboot with the latest from GlobalScale (ftp down for now) and maybe get a try with the ARMBIAN UBOOT also.

    #9069

    Gandalf
    Participant

    No more problem with another box, same operating system from same SATA

    #38399

    Shannon
    Participant

    I have 19.07 running reasonably well.
    It’s not perfect but it’s way better than any of the other similar boards (e.g. bpi-r2) I tested.
    It is forwarding at ~760 Mbps which is decent and there’s some post talking about tweaks that might make it faster.
    (This is sw-NAT, fully-routed.)

    If you don’t have a linux machine then setup a VPS from Uplcoud/Vultr/DigitalOcean and follow the OWRT instructions on how to build.
    “Flashing” the eb7 is trivial since it takes an SD card so you can just write the image to it using any image flashing tool like etcher.

    You can use PuTTY connect to the VPS and do the build then copy the image file back to your computer with WinSCP.

    Roughly:

    git clone https://git.openwrt.org/openwrt/openwrt.git/
    cd openwrt
    git checkout openwrt-19.07
    ./scripts/feeds update -a
    ./scripts/feeds install -a
    make menuconfig
    # Select Marvell EBU Armada
    # Select ESPRESSObin V7 (Marvell Armada 3700 Community Board)
    # Ensure LuCI is enabled (this is the web GUI)
    # Enable luci-app-commands luci-app-firewall luci-app-qos luci-app-uhttpd luci-app-upnp
    # I recommend enabling all of the Themes so you pick which one you like the best
    # Don’t enable stuff willy-nilly; not everything builds.
    # Enable stuff that you know you need.
    # Replace the 4 with the number of cores in you VPS
    make -j4

    I would build that and see it boot and work before adding other stuff you might want, e.g. 3G/4G support (via qmi).

    If you are using a wifi card then you need to enable the driver and the firmware for it.
    Aetheros devices come highly recommended.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop