Home Forums Software discussion OpenWRT build failing

This topic contains 2 replies, has 2 voices, and was last updated by  codemarauder 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1415

    codemarauder
    Participant

    Hi,

    I tried to compile the openwrt as per the instruction on the Wiki. The build compiled successfully once but after installing additional packages, I get following error:

    
    make -C /home/devuser/espressobin/openwrt-dd/build_dir/target-aarch64_cortex-a53+neon-vfpv4_musl-1.1.16/linux-mvebu64/linux-4.4.8 HOSTCFLAGS="-O2 -I/home/devuser/espressobin/openwrt-dd/staging_dir/host/include -I/home/devuser/espressobin/openwrt-dd/staging_dir/host/usr/include  -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="aarch64-openwrt-linux-musl-" ARCH="arm64" KBUILD_HAVE_NLS=no KBUILD_BUILD_USER="" KBUILD_BUILD_HOST="" CONFIG_SHELL="bash" V=''  CC="aarch64-openwrt-linux-musl-gcc" modules
    make[5]: Entering directory '/home/devuser/espressobin/openwrt-kernel'
      CHK     include/config/kernel.release
      CHK     include/generated/uapi/linux/version.h
      CHK     include/generated/utsrelease.h
      CHK     include/generated/bounds.h
      CHK     include/generated/timeconst.h
      CHK     include/generated/asm-offsets.h
      CALL    scripts/checksyscalls.sh
    usr/Makefile:64: *** multiple target patterns.  Stop.
    Makefile:949: recipe for target 'usr' failed
    make[5]: *** [usr] Error 2
    make[5]: Leaving directory '/home/devuser/espressobin/openwrt-kernel'
    Makefile:23: recipe for target '/home/devuser/espressobin/openwrt-dd/build_dir/target-aarch64_cortex-a53+neon-vfpv4_musl-1.1.16/linux-mvebu64/linux-4.4.8/.modules' failed
    make[4]: *** [/home/devuser/espressobin/openwrt-dd/build_dir/target-aarch64_cortex-a53+neon-vfpv4_musl-1.1.16/linux-mvebu64/linux-4.4.8/.modules] Error 2
    make[4]: Leaving directory '/home/devuser/espressobin/openwrt-dd/target/linux/mvebu64'
    Makefile:13: recipe for target 'compile' failed
    make[3]: *** [compile] Error 2
    make[3]: Leaving directory '/home/devuser/espressobin/openwrt-dd/target/linux'
    target/Makefile:21: recipe for target 'target/linux/compile' failed
    make[2]: *** [target/linux/compile] Error 2
    make[2]: Leaving directory '/home/devuser/espressobin/openwrt-dd'
    target/Makefile:16: recipe for target '/home/devuser/espressobin/openwrt-dd/staging_dir/target-aarch64_cortex-a53+neon-vfpv4_musl-1.1.16/stamp/.target_compile' failed
    make[1]: *** [/home/devuser/espressobin/openwrt-dd/staging_dir/target-aarch64_cortex-a53+neon-vfpv4_musl-1.1.16/stamp/.target_compile] Error 2
    make[1]: Leaving directory '/home/devuser/espressobin/openwrt-dd'
    /home/devuser/espressobin/openwrt-dd/include/toplevel.mk:192: recipe for target 'world' failed
    make: *** [world] Error 2
    

    I tried uninstalling all the package -> rm .config* -> make menuconfig (select target) -> make defconfig -> make -j1 V=s but still the same error.

    Any pointers on the same please? Thanks in advance.

    #1433

    akrog
    Keymaster

    Hi codemarauder,

    I don’t think the wiki instructions advise building like this; which additional packages were you trying to install?

    Please try the following, as you have likely selected one or more packages which have a kernel dependency:

    # in the openwrt-dd directory
    $ git status
    # if target/linux/mvebu64/config-4.4 has changed, checkout it with
    $ git checkout target/linux/mvebu64/config-4.4

    then try to build again, and let me know how it went.

    #1436

    codemarauder
    Participant

    Hi akrog,

    Thanks for your reply.

    I wanted to build additional packages like mwan3, squid, openvpn, qos/sqm scripts, luci etc. so as to use espressobin in my day to day practical scenario.

    I am looking at espressobin as an alternative to PC Engines APU2 in the networks with comparatively less number of users requiring less throughput and CPU cycles.

    Nothing seem to have changed in the cloned repository here though:

    
    git status
    On branch openwrt_17.02_release
    Your branch is up-to-date with 'origin/openwrt_17.02_release'.
    nothing to commit, working directory clean
    

    I had also asked at OpenWrt/LEDE mailing list and am able to successfully compile it from the repository:

    https://github.com/tmn505/source/tree/espressobin

    Apart from packages that do not have config available to be compiled for aarch64 like Perl and Squid, everything else is working including sysupgrade.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop