Home Forums Getting Started Testing without SD Card

Tagged: 

This topic contains 3 replies, has 1 voice, and was last updated by  ddombrowsky 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2644

    ddombrowsky
    Participant

    I just received my Espresso bin board and I don’t have the SD card for it yet.

    Shouldn’t it be possible to make sure the board is working by getting to the bootloader prompt? I plugged the power in and the device is recognized by the kernel, but nothing appears on the serial line.

    Will the board do anything if there is no SD card in it? Or is u-boot on the removable media also?

    #2646

    ddombrowsky
    Participant

    For that matter, the LED flickers once when I plug the thing in and will not stay on. So I’m thinking I either have a bad board or a bad power supply.

    #2972

    ddombrowsky
    Participant

    I got a new board. The power light stays on now, but still nothing on the serial line.

    Looks like this forum is dead.

    #2996

    ddombrowsky
    Participant

    For the record, I was able to get u-boot to come up without an SD card.

    I had to set the board into UART mode with the jumpers (see http://wiki.espressobin.net/tiki-index.php?page=Bootloader+recovery+via+UART), then get the “>” prompt to come up in that mode. Then switch back into normal boot mode. Then u-boot comes up. Note that I did NOT have to reload u-boot.

    I suspect the jumpers just weren’t seated correctly after shipping.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop