Home Forums Hardware discussions V7 bricked

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #41777
    libolt4
    Participant

    So I managed to brick my v7 board while trying to install arch linux. I followed the UART recovery guide and it flashes the recovery. However, when I reconnect to the Espressobin via screen /dev/ttyUSB0 115200. I still get the >

    Is there anything I can do to fix this? I’ve tried flashing several times with different versions of the recovery.

    #41785
    Kevin
    Keymaster

    Hi,
    Please try following to recovery
    Prepare a clean USB thumb drive and format to FAT/FAT32
    1. copy below files from ftp://downloads.globalscaletechnologies.com/Downloads/Espressobin/ESPRESSObin%20V7/recovery/ to USB thumb drive
    – Image
    – ramdisk
    – armada-3720-community.dtb
    – armada-3720-community-v7.dtb
    – espressobin-recovery.bin

    2. copy files in bootloader and rootfs floder from ftp://downloads.globalscaletechnologies.com/Downloads/Espressobin/ESPRESSObin%20V7/ to USB thumb drive
    – espressobin-rootfs-v0.8-20180129-REL.tar.gz
    – espressobin-bootloader-cpu-1000-*.bin
    – espressobin-bootloader-cpu-1200-*.bin

    3. Insert USB thumb drive to ESPRESSOBin v7. Power on ESPRESSOBin V7 then enter to u-boot console
    4. Enter below command to reflash bootlaoder, bootloader image. Please select according to your DDR size
    MARVELL>> bubt espressobin-bootloader-cpu-1000-ddr4-2cs-2g-atf-ga3306ab-uboot-gaee49fc-20180129-REL.bin spi usb
    5. Enter below command
    usb reset; fatload usb 0 $loadaddr espressobin-recovery.bin; source $loadaddr
    6. Enter below commands to install rootfs to eMMC
    mount /dev/sda1 /media
    cd /media
    ./mkemmc.sh espressobin-rootfs-v1.2-20180601-REL.tar.gz
    7. When done, restart system and enter into boot console
    8. Enter below commands and let ysytem boot from eMMC
    env default -asetenv image_name boot/Imagesetenv fdt_name boot/armada-3720-community-v7.dtb

    #41786
    libolt4
    Participant

    Kevin,

    Thank you for the response. I will give that a try and provide an updte when I have a free moment.

    Thank you again.

    #41788
    libolt4
    Participant

    So I have run into an issue downloading the Image file. It failed multiple times from Firefox so I tried with wget. Wget gets to 86% and fails. I specified -c to resume and it keeps attempting to resume but says “Data connection: connection reset by peer; Data transfer aborted.”

    #41789
    libolt4
    Participant

    Nevermind. I was able to download Image on my phone via my data connection and transfer it to my computer from there.

    #41790
    libolt4
    Participant

    Okay so I tried this and all I get is the > prompt then E if I press enter

    ? brings up

    
    h/? - print this help screen 
    r yyyyyyyy - read register/memory at address yyyyyyyy in hex 
    w yyyyyyyy zzzzzzzz - write zzzzzzzz to address yyyyyyyy in hex 
    j yyyyyyyy - jump to address yyyyyyyy in hex 
    x y - change the boot mode, where y is in hex 
    a - UART control passed to AP CPU ROM 
    c - UART control passed to CM3 CPU ROM 
    >
    

    Do I need to set the jumpers in a certain order, RIght now J3 and J11 are set to 2-3 and J10 is set to 1-2.

    Thank you,

    #41794
    libolt4
    Participant

    I just wanted to follow up and see if anyone had other ideas. I would really like to get this board working.

    Thank you,

    #41800
    libolt4
    Participant

    Is there anything else I can try? What doesn’t make sense to me is that I follow the UART recovery instructions, everything completes successfully and when I go back to the console it just as the > prompt.

    Also I have tried the different images for 1 gig and 2 gig boards as I am not sure what i have. I bought mine from Amazon: Globalscale Technologies, Inc. V7 64 Bit Single Board Computer Network Switch, ESPRESSOBIN+ board with Enclosure

    Is there a way I can tell by looking at the board?

    #41805
    Kevin
    Keymaster

    Hi,
    Does it come with a microSD card when you bought it from Amazon?

    #41806
    libolt4
    Participant

    It did not come with a microSD card. I had to use one I already owned by opening the case and plugging it into the board.

    #41856
    teknofarm
    Participant

    where i can buy it ?

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop