Home Forums Getting Started VLANs – OpenWRT

Tagged: ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #518
    sjose
    Participant

    I am trying configure VLANs on the Marvell switch so that I can use the LAN port as access ports such that lan0 and lan1 interfaces are on separate VLANs.
    With /etc/config/network file as below, I am unable to ping the LAN ports. What could I be missing here? Also what interface should I be running tcpdump on to verify the the packets are getting internally tagged?

    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config interface 'wan'
            option proto 'dhcp'
            option ifname 'wan'
    
    config 'switch' 'eth0'
            option 'enable' '1'
            option 'enable_vlan' '1'
            option 'reset' '1'
    
    config 'switch_vlan'
            option 'vlan' '2'
            option 'device' 'eth0'
            option 'ports' '2 5t'
    
    config 'switch_vlan'
            option 'vlan' '3'
            option 'device' 'eth0'
            option 'ports' '1 5t'
    
    config 'switch_port'
            option 'port' '1'
            option 'pvid' '3'
    
    config 'interface' 'lan0'
            option 'ifname' 'eth0.2'
            option 'proto' 'static'
            option 'ipaddr' '192.168.22.1'
            option 'netmask' '255.255.255.0'
    
    config 'interface' 'lan1'
            option 'ifname' 'eth0.3'
            option 'proto' 'static'
            option 'ipaddr' '192.168.24.1'
            option 'netmask' '255.255.255.0'
    #585
    akrog
    Keymaster

    Hello sjose,

    please consult the latest dts for correct physical interface names (ifname):

    https://github.com/MarvellEmbeddedProcessors/openwrt-kernel/blob/openwrt_17.02_release/arch/arm64/boot/dts/marvell/armada-3720-community.dts#L138

    e.g. try replacing ‘eth0.2’ with ‘lan0’ and ‘eth0.3’ with ‘lan1’.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop