Home Forums Hardware discussions Which PCIe wlan cards are supported?

This topic contains 66 replies, has 10 voices, and was last updated by  armbian 1 month, 3 weeks ago.

Viewing 15 posts - 31 through 45 (of 67 total)
  • Author
    Posts
  • #2153

    Xogium
    Participant

    Hi,
    thanks for your answer !
    I was expecting no answer, honestly, considering how many posts on here are sadly left without any kind of answers.
    As for the cpu, it is personally all I need. Load average never goes above 0.00 here honestly, even with gigabit. Then again I ported the ebin to modern buildroot since the marvell fork is long dead, and am using a read-only filesystem to avoid nasty data corruption seeing that both my parents and power outages are against the espresso lol. Used to run arch myself on it, but when I saw how often my folks disconnected it from the current thinking it was some typical router from a store, I rapidly changed my mind.

    As for the pcie slot, glad I’m not alone ! 😀
    I had also noticed that, but for me it happens so rarely I have not bothered with it much. Plus a reboot takes about 15 seconds…
    In all case I’ll be getting that card along with a full-size adapter, this looks promissing as every operation modes the linux wireless wiki lists seems to be supported, whereas mwifiex got a yes for AP mode and question marks at all the others.
    I’ll be back with hopefully some good news.
    Not sure how hard it will be for me to make that half-card fit in seeing I’m totally blind, but I will sure give it a go.
    Thanks !

    #2155

    tmn505
    Participant

    Hi Xogium,
    I see You still got problems with Your mwifiex card. Did You get to bisect the problematic commit?

    Regarding new wireless card, what are Your preferences? Which speed 802.11ac or 802.11n, which band 5GHz or 2.4GHz (the 2.4 narrows to 802.11n based cards)?

    #2156

    Xogium
    Participant

    Hi there,
    I did try to bisect the problem with the mwifiex driver for over one year, without any kind of success. Must have tried about 250 commits so far, and none proved to make it work again. I like to think I’m someone patient, but I just couldn’t stay on 4.12.12 kernel now that the ebin has improved a lot in 4.16 and 4.18, and will do so again in 4.20.

    As for new wireless cards, since it is not my personnal usage but rather that of my, sorry to say, quite ignorant family who don’t notice a single difference between a gigabit speed connection and a 30 mbit/s one, even a simple 150 mbps card would be more than enough for their usage. Rearding the capabilities, my mother’s cellphone cannot even see 5ghz networks so the choice is rather obvious, 2.4ghz it is.
    Thanks

    #2157

    tmn505
    Participant

    I myself would recommend any card which is using ath9k driver, but for that You’ll need to apply patch from this thread, http://espressobin.net/forums/topic/which-pcie-wlan-cards-are-supported/#post-1047. This is trivial one but it’ll be necessary to patch every kernel version. Maybe You can convince leming to add it to espressobin kernel. Armbian is using this patch and I didn’t read any compliant on their forum. A bit different one patch I made for OpenWrt is here: https://patchwork.ozlabs.org/patch/929648.

    As for the actual cards, search for AR5BHB116 on ebay (apply to description also), should fulfill Your needs (it’s half height card, so will need an adapter). If half-height cards are a problem, search for Compex WLE200NX (also ebay). Both of them are ath9k cards, so should work OOTB with mentioned patch.

    BTW, try the mentioned patch with Your mwifiex maybe it’ll help.

    #2158

    Xogium
    Participant

    Hi,
    I will try this thing for sure. Honestly, what can it hurt ? At best it works, at worse it crashes.
    😀

    As for a patch, I shall ask leming on the arch-arm side soon as I get 2 minutes to do it. It is slightly different in mainline kernel, hence why he didn’t apply your patch i.e: file is now linux-4.18.12/drivers/pci/controller/pci-aardvark.c. Line numbers are probably different, as well.
    Applying now, lets see what it does.

    #2159

    Xogium
    Participant

    Ah well, still a no go sadly.
    Mwifiex as bugged as ever: FW is in bad state, blah blah.
    Too bad, I guess.
    I’ll keep it handy for my ath9k card nonetheless.
    Thanks !

    #2160

    crazy4chrissi
    Participant

    Yes, I would definitely recommend ath9k as well. But from my experience, not every ath9k will work on the espressobin, even with the patch mentioned. So if you don’t want to order 5 cards, directly order QCWB335, this one works for me and some others. And no kernel patch required.

    @tmn505: Can you confirm AR5BHB116 works? AR5B22 does not work for me.

    #2162

    tmn505
    Participant

    I was using slightly different card with AR9380 chip instead of AR9382 which is in AR5BHB116, and I didn’t have any problems with it. Essentially both chips are same, the only difference is the first one is 3×3:3 and second is 2×2:2. The AR5BHB116 was tested only briefly (it usually sits in my laptop), but it also worked without issues.
    TBF I rarely look at combo cards with Bluetooth as that is useless for me, and often those cards are 1:1×1 which greatly reduce the throughput.

    @xogium Yes the paths have changed as guys from PCI reorganized the drivers a bit. With corrected paths the patch should apply with slight fuzz. I never sent them for inclusion to alarm because for network related gear i shifted to OpenWrt (systemd is PITA on unreliable storage like SD cards).

    To expand, maybe this workaround won’t be necessary in the future, there are pending patches related to aardvark which got accepted, I’m talking about this series: https://patchwork.ozlabs.org/cover/969080. If You’re for a challenge then go ahead, test this series. Unfortunately I can’t test them as my board is broken, locks up on RAM training (I’ll probably order the v7).

    #2163

    Xogium
    Participant

    I will probably test those. To be fair like I said in my second post here, I’m no longer using the ebin with archlinux, not due to issues with it but rather caused by my parents never understanding that no, they shouldn’t brutally unplug to poor thing while I’m doing updates !
    So I along with a guy that I happened to meet on irc one day, ported the ebin to modern buildroot aka 2018.08.1. Testing patch and stuff does not bother me as my entire OS has to be rebuilt for each new buildroot version, which I honestly don’t mind. The system is read-only along with a tmpfs /var which allows systemd to work just fine, while not risking to damage the storage itself, with a 15 mb data partition that is the only writable spot, to allow modifying iptables & ip6tables config, dnsmasq, etc. I could post the stuff (defconfig) if you want to have a look just for the fun, but do note that at this point it is meerly for personnal usage.

    Sad for your board, though 🙁

    I will probably never get a v7 ebin, as one ebin, complete with shipping costs about $240 cad, but it’s good to know it still evolves.

    #2184

    Xogium
    Participant

    Hi again,
    I just got my new cards, yay ! … Or not, already ran into trouble with them, both with a custom compiled kernel and the archlinux-arm one:
    http://ix.io/1pMX

    I tried both gen 1 and gen 2 for the pci slot.
    Anyone having any clue ?
    Can someone else with an atheros AR9565 aka. QCBW335 try it out ?

    #2187

    armbian
    Participant

    Did you update u-boot?

    #2189

    Xogium
    Participant

    Hi there,
    yes I did update to the latest u-boot available, 2017.03 armada v17.10.
    I had to do it because before the card was not working in u-boot, non posted status and all that. Now it is recognized, both in u-boot and in lspci, but the driver doesn’t want to play nice.

    I also tried to tweak kernel_addr, loadaddr, initrd_addr… Still a no go:

    * behavior with kernel < 4.14: tons of ‘modprobe: undefined instruction’, driver crashing in a similar way, and pci buss errors.
    * behavior with kernel >= 4.14: Only driver crashing, like my pastebin shows.

    #2190

    tmn505
    Participant

    That’s a bummer. Can You provide what patches are You using that touch pci-aardvark.c and on which kernel version?
    Also it would be helpful if You can test current stable (18.06) OpenWrt image an then snapshot image. To write the image to an SD card issue:
    zcat <openwrt-image>.img.gz | sudo dd of=/dev/<your-sd-card> oflag=sync
    To boot the image use this:
    setenv bootcmd "load mmc 0:1 0x4d00000 boot.scr; source 0x4d00000"
    After booting wan port should obtain ip address through dhcp. Make sure that You have internet connection. Then install kmod-ath9k with these commands:
    opkg update && opkg install kmod-ath9k
    After this please post dmesg for both stable and snapshot.

    #2192

    armbian
    Participant

    AFAIK latest U-boot is: U-Boot 2017.03-armada-18.09.1-ga92bd86-armbian (Sep 05 2018 – 21:49:34 +0200)

    Check here:

    Espressobin


    and here:
    https://forum.armbian.com/forum/32-armada-a388-a3700/

    IMO it’s best to stick with 4.18.y and newer.

    #2194

    Xogium
    Participant

    Hi,

    @tmn505
    yeah I can try openwrt now that the board was apparently ported to the modern version — marvell fork been dead for years.
    I’m always using 4.18.12 kernel, the 4.14.x and stuff was just for the sake of testing. The patchs for pci I use are the one included in arch-arm, meaning:
    http://ix.io/1pRg
    and
    http://ix.io/1pRh
    . After some digging over in #linux-wireless it appears the thing acts strangely. We checked the memory mapping and all, and the stack trace I showed in dmesg output was neatly pointing to the problem, a sigbus while reading a particular address… Which is mapped correctly.

    @armbian
    Yep, I agree that using 4.18 or later for kernel is the best, and I definitely plan on doing so which was the whole point of me getting this minipcie card rather than being held back by mwifiex.
    As for u-boot, I checked the tech specs section of the espressobin website, and the latest u-boot I found there was the one I mentioned. Maybe I simply missed it.

Viewing 15 posts - 31 through 45 (of 67 total)

You must be logged in to reply to this topic.

Signup to our newsletter

Technical specification tables can not be displayed on mobile. Please view on desktop